iOS4, iOS 4.2.1 cannot update anymore

Starting on 19 September 2012, Apple no longer made it possible for developers to build apps which support the iPhone 2G, 3G, iPod touch 1G and 2G: those devices are effectively deprecated by Apple.

The minimum required version for app updates on the App Store now is iOS 4.3, older version are not allowed by Apple anymore. Apple recommends all users to at least update to iOS 4.3.

Devices that cannot update to iOS 4.3 (iPhone 2G/3G, iPod touch 1G/2G) are unable to receive further App Store updates, as per Apple policy.

Week Calendar 5.0.3

The minimum required iOS version for Week Calendar 5.0.3 is iOS 4.3.

Supported iOS versions: 4.3 and newer.
Supported devices are iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPod touch 3rd generation, 4th generation, 5th generation.
iPad support, running as iPhone app: iPad 1, 2, 3, 4, iPad mini